Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 05, 2026 - 05:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 04, 2026 - 17:09 PDT
Scheduled
The TMU IT department will be conducting planned systems maintenance work from 5:00 am – 7:00 am PDT Tuesday, May 5, 2026. During this work window, we don't anticipate any significant service disruptions.
Posted May 04, 2026 - 17:07 PDT
This scheduled maintenance affected: Wi-Fi Network and Internet.