Canvas Outage

Incident Report for TMU IT Systems

Resolved

Canvas has restored access, and the TMU IT team has worked to re-establish a secure connection with the platform.

Please only access Canvas by signing in to https://masters.instructure.com using your "@masters.edu" account.
Posted May 08, 2026 - 08:04 PDT

Monitoring

Please be aware that Canvas is currently experiencing a major outage. Canvas is a third-party cloud solution and is not operated on a server maintained by TMU IT. Our support team is unable to resolve issues related to this outage.

You may follow Instructure's recovery efforts on their status page at https://status.instructure.com. We will send an update when Canvas provides further information.
Posted May 07, 2026 - 16:39 PDT
This incident affected: Canvas.