Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2026 - 05:00 PST
Scheduled
During this working window, you may experience interruptions to Self Service, TMU Central, the online billing portal, some Financial Aid resources for students, Reporting Viewer, and Key Manager.
Posted Mar 02, 2026 - 16:00 PST
This scheduled maintenance affected: TransactPayments (Cashnet), TMU Central, and Self Service.