Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 04, 2026 - 05:00 PST
Scheduled
During the 5am-7am Pacific Time maintenance windows, internet services to campus may be offline, as well as Self Service, TMU Central, VPN, and the online billing portal. Maintenance is scheduled during this early morning window to minimize disruptions, which we do not expect.
Posted Feb 03, 2026 - 21:52 PST
This scheduled maintenance affected: Internet, TransactPayments (Cashnet), TMU Central, Self Service, and VPN.