Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 05:00 PDT
Scheduled
During this window, several services will be unavailable, such as Self-Service, Registration Dashboard, and Billing Portal. Additionally, campus Wi-Fi may experience interruptions during this period.
Posted Mar 11, 2026 - 16:58 PDT
This scheduled maintenance affected: Wi-Fi Network, Internet, Wired Network, Web Print, Faculty/Staff Printing, TransactPayments (Cashnet), TMU Central, Self Service, and VPN.